<?xml version="1.0" encoding="UTF-8"?>
<cvrfdoc xmlns="http://www.icasi.org/CVRF/schema/cvrf/1.1" xmlns:cvrf="http://www.icasi.org/CVRF/schema/cvrf/1.1">
  <DocumentTitle xml:lang="en">Security update for google-gson</DocumentTitle>
  <DocumentType>SUSE Patch</DocumentType>
  <DocumentPublisher Type="Vendor">
    <ContactDetails>security@suse.de</ContactDetails>
    <IssuingAuthority>SUSE Security Team</IssuingAuthority>
  </DocumentPublisher>
  <DocumentTracking>
    <Identification>
      <ID>SUSE-SU-2022:3706-1</ID>
    </Identification>
    <Status>Final</Status>
    <Version>1</Version>
    <RevisionHistory>
      <Revision>
        <Number>1</Number>
        <Date>2022-10-24T13:19:55Z</Date>
        <Description>current</Description>
      </Revision>
    </RevisionHistory>
    <InitialReleaseDate>2022-10-24T13:19:55Z</InitialReleaseDate>
    <CurrentReleaseDate>2022-10-24T13:19:55Z</CurrentReleaseDate>
    <Generator>
      <Engine>cve-database/bin/generate-cvrf.pl</Engine>
      <Date>2017-02-24T01:00:00Z</Date>
    </Generator>
  </DocumentTracking>
  <DocumentNotes>
    <Note Title="Topic" Type="Summary" Ordinal="1" xml:lang="en">Security update for google-gson</Note>
    <Note Title="Details" Type="General" Ordinal="2" xml:lang="en">This update for google-gson fixes the following issues:

Fixed security issue:

- CVE-2022-25647: Deserialization of Untrusted Data (bsc#1199064)

Other non security fixes:

- Build with Java &gt;= 9 in order to produce a modular jar by
  compiling the module-info.java sources with all other classes
  built with release 8 and still compatible with Java 8
- Upgrade to version 2.8.9 (jsc#SLE-24261)
  * Make OSGi bundle's dependency on sun.misc optional.
  * Deprecate Gson.excluder() exposing internal Excluder class.
  * Prevent Java deserialization of internal classes.
  * Improve number strategy implementation.
  * Fix LongSerializationPolicy null handling being inconsistent with Gson.
  * Support arbitrary Number implementation for Object and Number deserialization.
  * Bump proguard-maven-plugin from 2.4.0 to 2.5.1.
  * Don't exclude static local classes.
  * Fix RuntimeTypeAdapterFactory depending on internal Streams class.
  * Improve Maven build.
  * Make dependency on java.sql optional.
  * Fixed issue with recursive types.
  * Better behavior with Java 9+ and Unsafe if there is a security manager.
  * EnumTypeAdapter now works better when ProGuard has obfuscated enum fields.
  *  make import of sun.misc optional since not all versions of jdk export it
</Note>
    <Note Title="Terms of Use" Type="Legal Disclaimer" Ordinal="3" xml:lang="en">The CVRF data is provided by SUSE under the Creative Commons License 4.0 with Attribution (CC-BY-4.0).</Note>
    <Note Title="Patchnames" Type="Details" Ordinal="4" xml:lang="en">SUSE-2022-3706,SUSE-SLE-Module-SUSE-Manager-Server-4.1-2022-3706</Note>
  </DocumentNotes>
  <DocumentDistribution xml:lang="en">Copyright SUSE LLC under the Creative Commons License 4.0 with Attribution (CC-BY-4.0)</DocumentDistribution>
  <DocumentReferences>
    <Reference Type="Self">
      <URL>https://www.suse.com/support/update/announcement/2022/suse-su-20223706-1/</URL>
      <Description>Link for SUSE-SU-2022:3706-1</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://lists.suse.com/pipermail/sle-security-updates/2022-October/012637.html</URL>
      <Description>E-Mail link for SUSE-SU-2022:3706-1</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://www.suse.com/support/security/rating/</URL>
      <Description>SUSE Security Ratings</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://bugzilla.suse.com/1199064</URL>
      <Description>SUSE Bug 1199064</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://www.suse.com/security/cve/CVE-2022-25647/</URL>
      <Description>SUSE CVE CVE-2022-25647 page</Description>
    </Reference>
  </DocumentReferences>
  <ProductTree xmlns="http://www.icasi.org/CVRF/schema/prod/1.1">
    <Branch Type="Product Family" Name="SUSE Manager Server Module 4.1">
      <Branch Type="Product Name" Name="SUSE Manager Server Module 4.1">
        <FullProductName ProductID="SUSE Manager Server Module 4.1" CPE="cpe:/o:suse:sle-module-suse-manager-server:4.1">SUSE Manager Server Module 4.1</FullProductName>
      </Branch>
    </Branch>
    <Branch Type="Product Version" Name="google-gson-2.8.9-150200.3.7.1">
      <FullProductName ProductID="google-gson-2.8.9-150200.3.7.1">google-gson-2.8.9-150200.3.7.1</FullProductName>
    </Branch>
    <Branch Type="Product Version" Name="google-gson-javadoc-2.8.9-150200.3.7.1">
      <FullProductName ProductID="google-gson-javadoc-2.8.9-150200.3.7.1">google-gson-javadoc-2.8.9-150200.3.7.1</FullProductName>
    </Branch>
    <Relationship ProductReference="google-gson-2.8.9-150200.3.7.1" RelationType="Default Component Of" RelatesToProductReference="SUSE Manager Server Module 4.1">
      <FullProductName ProductID="SUSE Manager Server Module 4.1:google-gson-2.8.9-150200.3.7.1">google-gson-2.8.9-150200.3.7.1 as a component of SUSE Manager Server Module 4.1</FullProductName>
    </Relationship>
  </ProductTree>
  <Vulnerability xmlns="http://www.icasi.org/CVRF/schema/vuln/1.1" Ordinal="1">
    <Notes>
      <Note Title="Vulnerability Description" Type="General" Ordinal="1" xml:lang="en">The package com.google.code.gson:gson before 2.8.9 are vulnerable to Deserialization of Untrusted Data via the writeReplace() method in internal classes, which may lead to DoS attacks.</Note>
    </Notes>
    <CVE>CVE-2022-25647</CVE>
    <ProductStatuses>
      <Status Type="Fixed">
        <ProductID>SUSE Manager Server Module 4.1:google-gson-2.8.9-150200.3.7.1</ProductID>
      </Status>
    </ProductStatuses>
    <Threats>
      <Threat Type="Impact">
        <Description>important</Description>
      </Threat>
    </Threats>
    <Remediations>
      <Remediation Type="Vendor Fix">
        <Description xml:lang="en">To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
</Description>
        <URL>https://www.suse.com/support/update/announcement/2022/suse-su-20223706-1/</URL>
      </Remediation>
    </Remediations>
    <References>
      <Reference>
        <URL>https://www.suse.com/security/cve/CVE-2022-25647.html</URL>
        <Description>CVE-2022-25647</Description>
      </Reference>
      <Reference>
        <URL>https://bugzilla.suse.com/1199064</URL>
        <Description>SUSE Bug 1199064</Description>
      </Reference>
    </References>
  </Vulnerability>
</cvrfdoc>
