<?xml version="1.0" encoding="UTF-8"?>
<cvrfdoc xmlns="http://www.icasi.org/CVRF/schema/cvrf/1.1" xmlns:cvrf="http://www.icasi.org/CVRF/schema/cvrf/1.1">
  <DocumentTitle xml:lang="en">Security update for php8-pear</DocumentTitle>
  <DocumentType>SUSE Patch</DocumentType>
  <DocumentPublisher Type="Vendor">
    <ContactDetails>security@suse.de</ContactDetails>
    <IssuingAuthority>SUSE Security Team</IssuingAuthority>
  </DocumentPublisher>
  <DocumentTracking>
    <Identification>
      <ID>SUSE-SU-2022:3198-1</ID>
    </Identification>
    <Status>Final</Status>
    <Version>1</Version>
    <RevisionHistory>
      <Revision>
        <Number>1</Number>
        <Date>2022-09-08T08:36:07Z</Date>
        <Description>current</Description>
      </Revision>
    </RevisionHistory>
    <InitialReleaseDate>2022-09-08T08:36:07Z</InitialReleaseDate>
    <CurrentReleaseDate>2022-09-08T08:36:07Z</CurrentReleaseDate>
    <Generator>
      <Engine>cve-database/bin/generate-cvrf.pl</Engine>
      <Date>2017-02-24T01:00:00Z</Date>
    </Generator>
  </DocumentTracking>
  <DocumentNotes>
    <Note Title="Topic" Type="Summary" Ordinal="1" xml:lang="en">Security update for php8-pear</Note>
    <Note Title="Details" Type="General" Ordinal="2" xml:lang="en">This update for php8-pear fixes the following issues:

- Add php8-pear to SLE15-SP4 (jsc#SLE-24728)
- Update to 1.10.21
  - PEAR 1.10.13
    * unsupported protocol - use --force to continue
    * Add $this operator to _determineIfPowerpc calls
- Update to 1.10.20
  - Archive_Tar 1.4.14
    * Properly fix symbolic link path traversal (CVE-2021-32610)
  - Archive_Tar 1.4.13
    * Relative symlinks failing (out-of path file extraction)
  - Archive_Tar 1.4.12
  - Archive_Tar 1.4.11
  - Archive_Tar 1.4.10
    * Fix block padding when the file buffer length is a multiple
      of 512 and smaller than Archive_Tar buffer length
    * Don't try to copy username/groupname in chroot jail

- provides and obsoletes php7-pear-Archive_Tar, former location
  of PEAR/Archive/Tar.php

- Update to version 1.10.19
  - PEAR 1.10.12
    * adjust dependencies based on new releases
  - XML_Util 1.4.5
    * fix Trying to access array offset on value of type int

- Update to version 1.10.18
- Remove pear-cacheid-array-check.patch (upstreamed)
- Contents of .filemap are now sorted internally

- Sort contents of .filemap to make build reproducible

- Recommend php7-openssl to allow https sources to be used
- Modify metadata_dir for system configuration only
- Add /var/lib/pear directory where xml files are stored
- Cleanup %files section

- Only use the GPG keys of Chuck Burgess. Extracted from the 
  Release Manager public keys.
- Add release versions of PEAR modules

- Install metadata files (registry, filemap, channels, ...) in
  /var/lib/pear/ instead of /usr/share/php7/PEAR/

- Update to version 1.10.17
</Note>
    <Note Title="Terms of Use" Type="Legal Disclaimer" Ordinal="3" xml:lang="en">The CVRF data is provided by SUSE under the Creative Commons License 4.0 with Attribution (CC-BY-4.0).</Note>
    <Note Title="Patchnames" Type="Details" Ordinal="4" xml:lang="en">SUSE-2022-3198,SUSE-SLE-Module-Web-Scripting-15-SP4-2022-3198</Note>
  </DocumentNotes>
  <DocumentDistribution xml:lang="en">Copyright SUSE LLC under the Creative Commons License 4.0 with Attribution (CC-BY-4.0)</DocumentDistribution>
  <DocumentReferences>
    <Reference Type="Self">
      <URL>https://www.suse.com/support/update/announcement/2022/suse-su-20223198-1/</URL>
      <Description>Link for SUSE-SU-2022:3198-1</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://lists.suse.com/pipermail/sle-security-updates/2022-September/012180.html</URL>
      <Description>E-Mail link for SUSE-SU-2022:3198-1</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://www.suse.com/support/security/rating/</URL>
      <Description>SUSE Security Ratings</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://www.suse.com/security/cve/CVE-2021-32610/</URL>
      <Description>SUSE CVE CVE-2021-32610 page</Description>
    </Reference>
  </DocumentReferences>
  <ProductTree xmlns="http://www.icasi.org/CVRF/schema/prod/1.1">
    <Branch Type="Product Family" Name="SUSE Linux Enterprise Module for Web and Scripting 15 SP4">
      <Branch Type="Product Name" Name="SUSE Linux Enterprise Module for Web and Scripting 15 SP4">
        <FullProductName ProductID="SUSE Linux Enterprise Module for Web and Scripting 15 SP4" CPE="cpe:/o:suse:sle-module-web-scripting:15:sp4">SUSE Linux Enterprise Module for Web and Scripting 15 SP4</FullProductName>
      </Branch>
    </Branch>
    <Branch Type="Product Version" Name="php8-pear-1.10.21-150400.9.3.1">
      <FullProductName ProductID="php8-pear-1.10.21-150400.9.3.1">php8-pear-1.10.21-150400.9.3.1</FullProductName>
    </Branch>
    <Branch Type="Product Version" Name="php8-pecl-1.10.21-150400.9.3.1">
      <FullProductName ProductID="php8-pecl-1.10.21-150400.9.3.1">php8-pecl-1.10.21-150400.9.3.1</FullProductName>
    </Branch>
    <Relationship ProductReference="php8-pear-1.10.21-150400.9.3.1" RelationType="Default Component Of" RelatesToProductReference="SUSE Linux Enterprise Module for Web and Scripting 15 SP4">
      <FullProductName ProductID="SUSE Linux Enterprise Module for Web and Scripting 15 SP4:php8-pear-1.10.21-150400.9.3.1">php8-pear-1.10.21-150400.9.3.1 as a component of SUSE Linux Enterprise Module for Web and Scripting 15 SP4</FullProductName>
    </Relationship>
    <Relationship ProductReference="php8-pecl-1.10.21-150400.9.3.1" RelationType="Default Component Of" RelatesToProductReference="SUSE Linux Enterprise Module for Web and Scripting 15 SP4">
      <FullProductName ProductID="SUSE Linux Enterprise Module for Web and Scripting 15 SP4:php8-pecl-1.10.21-150400.9.3.1">php8-pecl-1.10.21-150400.9.3.1 as a component of SUSE Linux Enterprise Module for Web and Scripting 15 SP4</FullProductName>
    </Relationship>
  </ProductTree>
  <Vulnerability xmlns="http://www.icasi.org/CVRF/schema/vuln/1.1" Ordinal="1">
    <Notes>
      <Note Title="Vulnerability Description" Type="General" Ordinal="1" xml:lang="en">In Archive_Tar before 1.4.14, symlinks can refer to targets outside of the extracted archive, a different vulnerability than CVE-2020-36193.</Note>
    </Notes>
    <CVE>CVE-2021-32610</CVE>
    <ProductStatuses>
      <Status Type="Fixed">
        <ProductID>SUSE Linux Enterprise Module for Web and Scripting 15 SP4:php8-pear-1.10.21-150400.9.3.1</ProductID>
        <ProductID>SUSE Linux Enterprise Module for Web and Scripting 15 SP4:php8-pecl-1.10.21-150400.9.3.1</ProductID>
      </Status>
    </ProductStatuses>
    <Threats>
      <Threat Type="Impact">
        <Description>moderate</Description>
      </Threat>
    </Threats>
    <Remediations>
      <Remediation Type="Vendor Fix">
        <Description xml:lang="en">To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
</Description>
        <URL>https://www.suse.com/support/update/announcement/2022/suse-su-20223198-1/</URL>
      </Remediation>
    </Remediations>
    <References>
      <Reference>
        <URL>https://www.suse.com/security/cve/CVE-2021-32610.html</URL>
        <Description>CVE-2021-32610</Description>
      </Reference>
    </References>
  </Vulnerability>
</cvrfdoc>
