<?xml version="1.0" encoding="UTF-8"?>
<cvrfdoc xmlns="http://www.icasi.org/CVRF/schema/cvrf/1.1" xmlns:cvrf="http://www.icasi.org/CVRF/schema/cvrf/1.1">
  <DocumentTitle xml:lang="en">Security update for netty</DocumentTitle>
  <DocumentType>SUSE Patch</DocumentType>
  <DocumentPublisher Type="Vendor">
    <ContactDetails>security@suse.de</ContactDetails>
    <IssuingAuthority>SUSE Security Team</IssuingAuthority>
  </DocumentPublisher>
  <DocumentTracking>
    <Identification>
      <ID>SUSE-SU-2022:1315-1</ID>
    </Identification>
    <Status>Final</Status>
    <Version>1</Version>
    <RevisionHistory>
      <Revision>
        <Number>1</Number>
        <Date>2022-04-22T15:00:17Z</Date>
        <Description>current</Description>
      </Revision>
    </RevisionHistory>
    <InitialReleaseDate>2022-04-22T15:00:17Z</InitialReleaseDate>
    <CurrentReleaseDate>2022-04-22T15:00:17Z</CurrentReleaseDate>
    <Generator>
      <Engine>cve-database/bin/generate-cvrf.pl</Engine>
      <Date>2017-02-24T01:00:00Z</Date>
    </Generator>
  </DocumentTracking>
  <DocumentNotes>
    <Note Title="Topic" Type="Summary" Ordinal="1" xml:lang="en">Security update for netty</Note>
    <Note Title="Details" Type="General" Ordinal="2" xml:lang="en">This update for netty fixes the following issues:

- CVE-2021-21409: Fixed request smuggling via content-length header (bsc#1184203).
</Note>
    <Note Title="Terms of Use" Type="Legal Disclaimer" Ordinal="3" xml:lang="en">The CVRF data is provided by SUSE under the Creative Commons License 4.0 with Attribution (CC-BY-4.0).</Note>
    <Note Title="Patchnames" Type="Details" Ordinal="4" xml:lang="en">SUSE-2022-1315,openSUSE-SLE-15.3-2022-1315,openSUSE-SLE-15.4-2022-1315</Note>
  </DocumentNotes>
  <DocumentDistribution xml:lang="en">Copyright SUSE LLC under the Creative Commons License 4.0 with Attribution (CC-BY-4.0)</DocumentDistribution>
  <DocumentReferences>
    <Reference Type="Self">
      <URL>https://www.suse.com/support/update/announcement/2022/suse-su-20221315-1/</URL>
      <Description>Link for SUSE-SU-2022:1315-1</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://lists.suse.com/pipermail/sle-security-updates/2022-April/010800.html</URL>
      <Description>E-Mail link for SUSE-SU-2022:1315-1</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://www.suse.com/support/security/rating/</URL>
      <Description>SUSE Security Ratings</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://bugzilla.suse.com/1184203</URL>
      <Description>SUSE Bug 1184203</Description>
    </Reference>
    <Reference Type="Self">
      <URL>https://www.suse.com/security/cve/CVE-2021-21409/</URL>
      <Description>SUSE CVE CVE-2021-21409 page</Description>
    </Reference>
  </DocumentReferences>
  <ProductTree xmlns="http://www.icasi.org/CVRF/schema/prod/1.1">
    <Branch Type="Product Family" Name="openSUSE Leap 15.3">
      <Branch Type="Product Name" Name="openSUSE Leap 15.3">
        <FullProductName ProductID="openSUSE Leap 15.3" CPE="cpe:/o:opensuse:leap:15.3">openSUSE Leap 15.3</FullProductName>
      </Branch>
    </Branch>
    <Branch Type="Product Version" Name="netty-4.1.75-150200.4.9.1">
      <FullProductName ProductID="netty-4.1.75-150200.4.9.1">netty-4.1.75-150200.4.9.1</FullProductName>
    </Branch>
    <Branch Type="Product Version" Name="netty-javadoc-4.1.75-150200.4.9.1">
      <FullProductName ProductID="netty-javadoc-4.1.75-150200.4.9.1">netty-javadoc-4.1.75-150200.4.9.1</FullProductName>
    </Branch>
    <Branch Type="Product Version" Name="netty-poms-4.1.75-150200.4.9.1">
      <FullProductName ProductID="netty-poms-4.1.75-150200.4.9.1">netty-poms-4.1.75-150200.4.9.1</FullProductName>
    </Branch>
    <Relationship ProductReference="netty-4.1.75-150200.4.9.1" RelationType="Default Component Of" RelatesToProductReference="openSUSE Leap 15.3">
      <FullProductName ProductID="openSUSE Leap 15.3:netty-4.1.75-150200.4.9.1">netty-4.1.75-150200.4.9.1 as a component of openSUSE Leap 15.3</FullProductName>
    </Relationship>
    <Relationship ProductReference="netty-javadoc-4.1.75-150200.4.9.1" RelationType="Default Component Of" RelatesToProductReference="openSUSE Leap 15.3">
      <FullProductName ProductID="openSUSE Leap 15.3:netty-javadoc-4.1.75-150200.4.9.1">netty-javadoc-4.1.75-150200.4.9.1 as a component of openSUSE Leap 15.3</FullProductName>
    </Relationship>
    <Relationship ProductReference="netty-poms-4.1.75-150200.4.9.1" RelationType="Default Component Of" RelatesToProductReference="openSUSE Leap 15.3">
      <FullProductName ProductID="openSUSE Leap 15.3:netty-poms-4.1.75-150200.4.9.1">netty-poms-4.1.75-150200.4.9.1 as a component of openSUSE Leap 15.3</FullProductName>
    </Relationship>
  </ProductTree>
  <Vulnerability xmlns="http://www.icasi.org/CVRF/schema/vuln/1.1" Ordinal="1">
    <Notes>
      <Note Title="Vulnerability Description" Type="General" Ordinal="1" xml:lang="en">Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers &amp; clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.</Note>
    </Notes>
    <CVE>CVE-2021-21409</CVE>
    <ProductStatuses>
      <Status Type="Fixed">
        <ProductID>openSUSE Leap 15.3:netty-4.1.75-150200.4.9.1</ProductID>
        <ProductID>openSUSE Leap 15.3:netty-javadoc-4.1.75-150200.4.9.1</ProductID>
        <ProductID>openSUSE Leap 15.3:netty-poms-4.1.75-150200.4.9.1</ProductID>
      </Status>
    </ProductStatuses>
    <Threats>
      <Threat Type="Impact">
        <Description>moderate</Description>
      </Threat>
    </Threats>
    <Remediations>
      <Remediation Type="Vendor Fix">
        <Description xml:lang="en">To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
</Description>
        <URL>https://www.suse.com/support/update/announcement/2022/suse-su-20221315-1/</URL>
      </Remediation>
    </Remediations>
    <References>
      <Reference>
        <URL>https://www.suse.com/security/cve/CVE-2021-21409.html</URL>
        <Description>CVE-2021-21409</Description>
      </Reference>
      <Reference>
        <URL>https://bugzilla.suse.com/1184203</URL>
        <Description>SUSE Bug 1184203</Description>
      </Reference>
    </References>
  </Vulnerability>
</cvrfdoc>
